$re = '/==(\w.*?)==/m';
$str = '==this is a test==
here ==is another test== and yet ==some other test==';
$subst = "==<mark>$1</mark>==";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;