package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)==(\w.*?)==`)
var str = `==this is a test==
here ==is another test== and yet ==some other test==`
var substitution = "==<mark>$1</mark>=="
fmt.Println(re.ReplaceAllString(str, substitution))
}