import Foundation
let pattern = #"==(\w.*?)=="#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
==this is a test==
here ==is another test== and yet ==some other test==
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"==<mark>$1</mark>=="#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)