#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".*(7\d{6}).*"
Local $sString = "aksjhaksghlkas NSLsf" & @CRLF & _
"sklvbaskjhbvak vjadv 09,00mm" & @CRLF & _
"123456416584 7001122 asvljalskjfg 564563" & @CRLF & _
"34893 ajksha"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)