const regex = /.*(7\d{6}).*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*(7\\d{6}).*', 'g')
const str = `aksjhaksghlkas NSLsf
sklvbaskjhbvak vjadv 09,00mm
123456416584 7001122 asvljalskjfg 564563
34893 ajksha`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);