re = /.*(7\d{6}).*/
str = 'aksjhaksghlkas NSLsf
sklvbaskjhbvak vjadv 09,00mm
123456416584 7001122 asvljalskjfg 564563
34893 ajksha'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result