// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*(7\d{6}).*").unwrap();
let string = "aksjhaksghlkas NSLsf
sklvbaskjhbvak vjadv 09,00mm
123456416584 7001122 asvljalskjfg 564563
34893 ajksha";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}