#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:class|href)([\s='"./]+)([\w-./?=&\\#"]+)((['#\\&?=/".\w\d]+|[\w)('-."\s]+)['"]|)"
Local $sString = "<a href=test.html/?v=1#subject\login class=xyz data="blah" myattr="example">" & @CRLF & _
"<a href = test.html class=xyz data=' blah'>" & @CRLF & _
"<a href= "test . html" class=" xyz " data=blah>" & @CRLF & _
"<a href = ' ./test.html#bir/deneme/?k=1&v=1 ' class= "a xyz_bir-ahmet. abc">" & @CRLF & _
"<a href = ' ./test.html' class= 'xyz abc'>" & @CRLF & _
"<a href = ' .././test.html' class= 'xyz abc'>" & @CRLF & _
"<a href = 'test.html' class = " xyz ui abc">" & @CRLF & _
"<a href='test.html' class ='xyz ui abc'>" & @CRLF & _
"<a href="test.html" class=" xyz ui abc">" & @CRLF & _
"<a href= "test.html " class="xyz "data=blah>" & @CRLF & _
"<a href=test.html class="xyz " data=blah>" & @CRLF & _
"<a href=test.html class="xyz" data=blah>" & @CRLF & _
"<a href=test.html class = xyz data="blah">" & @CRLF & _
"<meta http-equiv="Set-Cookie" content="COOKIE2_VALUE_HERE">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")