import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:class|href)([\\s='\"./]+)([\\w-./?=&\\\\#\"]+)((['#\\\\&?=/\".\\w\\d]+|[\\w)('-.\"\\s]+)['\"]|)";
final String string = "<a href=test.html/?v=1#subject\\login class=xyz data=\"blah\" myattr=\"example\">\n"
+ "<a href = test.html class=xyz data=' blah'>\n"
+ "<a href= \"test . html\" class=\" xyz \" data=blah>\n"
+ "<a href = ' ./test.html#bir/deneme/?k=1&v=1 ' class= \"a xyz_bir-ahmet. abc\">\n"
+ "<a href = ' ./test.html' class= 'xyz abc'>\n"
+ "<a href = ' .././test.html' class= 'xyz abc'>\n"
+ "<a href = 'test.html' class = \" xyz ui abc\">\n"
+ "<a href='test.html' class ='xyz ui abc'>\n"
+ "<a href=\"test.html\" class=\" xyz ui abc\">\n"
+ "<a href= \"test.html \" class=\"xyz \"data=blah>\n"
+ "<a href=test.html class=\"xyz \" data=blah>\n"
+ "<a href=test.html class=\"xyz\" data=blah>\n"
+ "<a href=test.html class = xyz data=\"blah\">\n"
+ "<meta http-equiv=\"Set-Cookie\" content=\"COOKIE2_VALUE_HERE\">";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}