// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?:class|href)([\s='"./]+)([\w-./?=&\\#"]+)((['#\\&?=/".\w\d]+|[\w)('-."\s]+)['"]|)"#).unwrap();
let string = "<a href=test.html/?v=1#subject\\login class=xyz data=\"blah\" myattr=\"example\">
<a href = test.html class=xyz data=' blah'>
<a href= \"test . html\" class=\" xyz \" data=blah>
<a href = ' ./test.html#bir/deneme/?k=1&v=1 ' class= \"a xyz_bir-ahmet. abc\">
<a href = ' ./test.html' class= 'xyz abc'>
<a href = ' .././test.html' class= 'xyz abc'>
<a href = 'test.html' class = \" xyz ui abc\">
<a href='test.html' class ='xyz ui abc'>
<a href=\"test.html\" class=\" xyz ui abc\">
<a href= \"test.html \" class=\"xyz \"data=blah>
<a href=test.html class=\"xyz \" data=blah>
<a href=test.html class=\"xyz\" data=blah>
<a href=test.html class = xyz data=\"blah\">
<meta http-equiv=\"Set-Cookie\" content=\"COOKIE2_VALUE_HERE\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}