import Foundation
let pattern = ##"(?:class|href)([\s='"./]+)([\w-./?=&\\#"]+)((['#\\&?=/".\w\d]+|[\w)('-."\s]+)['"]|)"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
<a href=test.html/?v=1#subject\login class=xyz data="blah" myattr="example">
<a href = test.html class=xyz data=' blah'>
<a href= "test . html" class=" xyz " data=blah>
<a href = ' ./test.html#bir/deneme/?k=1&v=1 ' class= "a xyz_bir-ahmet. abc">
<a href = ' ./test.html' class= 'xyz abc'>
<a href = ' .././test.html' class= 'xyz abc'>
<a href = 'test.html' class = " xyz ui abc">
<a href='test.html' class ='xyz ui abc'>
<a href="test.html" class=" xyz ui abc">
<a href= "test.html " class="xyz "data=blah>
<a href=test.html class="xyz " data=blah>
<a href=test.html class="xyz" data=blah>
<a href=test.html class = xyz data="blah">
<meta http-equiv="Set-Cookie" content="COOKIE2_VALUE_HERE">
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)