use strict;
my $str = '<a href=test.html/?v=1#subject\\login class=xyz data="blah" myattr="example">
<a href = test.html class=xyz data=\' blah\'>
<a href= "test . html" class=" xyz " data=blah>
<a href = \' ./test.html#bir/deneme/?k=1&v=1 \' class= "a xyz_bir-ahmet. abc">
<a href = \' ./test.html\' class= \'xyz abc\'>
<a href = \' .././test.html\' class= \'xyz abc\'>
<a href = \'test.html\' class = " xyz ui abc">
<a href=\'test.html\' class =\'xyz ui abc\'>
<a href="test.html" class=" xyz ui abc">
<a href= "test.html " class="xyz "data=blah>
<a href=test.html class="xyz " data=blah>
<a href=test.html class="xyz" data=blah>
<a href=test.html class = xyz data="blah">
<meta http-equiv="Set-Cookie" content="COOKIE2_VALUE_HERE">';
my $regex = qr/(?:class|href)([\s='"./]+)([\w-./?=&\\#"]+)((['#\\&?=/".\w\d]+|[\w)('-."\s]+)['"]|)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}