# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:class|href)([\s='\"./]+)([\w-./?=&\\#\"]+)((['#\\&?=/\".\w\d]+|[\w)('-.\"\s]+)['\"]|)"
test_str = ("<a href=test.html/?v=1#subject\\login class=xyz data=\"blah\" myattr=\"example\">\n"
"<a href = test.html class=xyz data=' blah'>\n"
"<a href= \"test . html\" class=\" xyz \" data=blah>\n"
"<a href = ' ./test.html#bir/deneme/?k=1&v=1 ' class= \"a xyz_bir-ahmet. abc\">\n"
"<a href = ' ./test.html' class= 'xyz abc'>\n"
"<a href = ' .././test.html' class= 'xyz abc'>\n"
"<a href = 'test.html' class = \" xyz ui abc\">\n"
"<a href='test.html' class ='xyz ui abc'>\n"
"<a href=\"test.html\" class=\" xyz ui abc\">\n"
"<a href= \"test.html \" class=\"xyz \"data=blah>\n"
"<a href=test.html class=\"xyz \" data=blah>\n"
"<a href=test.html class=\"xyz\" data=blah>\n"
"<a href=test.html class = xyz data=\"blah\">\n"
"<meta http-equiv=\"Set-Cookie\" content=\"COOKIE2_VALUE_HERE\">")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.