using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:class|href)([\s='""./]+)([\w-./?=&\\#""]+)((['#\\&?=/"".\w\d]+|[\w)('-.""\s]+)['""]|)";
string input = @"<a href=test.html/?v=1#subject\login class=xyz data=""blah"" myattr=""example"">
<a href = test.html class=xyz data=' blah'>
<a href= ""test . html"" class="" xyz "" data=blah>
<a href = ' ./test.html#bir/deneme/?k=1&v=1 ' class= ""a xyz_bir-ahmet. abc"">
<a href = ' ./test.html' class= 'xyz abc'>
<a href = ' .././test.html' class= 'xyz abc'>
<a href = 'test.html' class = "" xyz ui abc"">
<a href='test.html' class ='xyz ui abc'>
<a href=""test.html"" class="" xyz ui abc"">
<a href= ""test.html "" class=""xyz ""data=blah>
<a href=test.html class=""xyz "" data=blah>
<a href=test.html class=""xyz"" data=blah>
<a href=test.html class = xyz data=""blah"">
<meta http-equiv=""Set-Cookie"" content=""COOKIE2_VALUE_HERE"">";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}