const regex = /(?:class|href)([\s='"./]+)([\w-./?=&\\#"]+)((['#\\&?=/".\w\d]+|[\w)('-."\s]+)['"]|)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:class|href)([\\s=\'".\/]+)([\\w-.\/?=&\\\\#"]+)(([\'#\\\\&?=\/".\\w\\d]+|[\\w)(\'-."\\s]+)[\'"]|)', 'g')
const str = `<a href=test.html/?v=1#subject\\login class=xyz data="blah" myattr="example">
<a href = test.html class=xyz data=' blah'>
<a href= "test . html" class=" xyz " data=blah>
<a href = ' ./test.html#bir/deneme/?k=1&v=1 ' class= "a xyz_bir-ahmet. abc">
<a href = ' ./test.html' class= 'xyz abc'>
<a href = ' .././test.html' class= 'xyz abc'>
<a href = 'test.html' class = " xyz ui abc">
<a href='test.html' class ='xyz ui abc'>
<a href="test.html" class=" xyz ui abc">
<a href= "test.html " class="xyz "data=blah>
<a href=test.html class="xyz " data=blah>
<a href=test.html class="xyz" data=blah>
<a href=test.html class = xyz data="blah">
<meta http-equiv="Set-Cookie" content="COOKIE2_VALUE_HERE">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}