package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:class|href)([\s='"./]+)([\w-./?=&\\#"]+)((['#\\&?=/".\w\d]+|[\w)('-."\s]+)['"]|)`)
var str = `<a href=test.html/?v=1#subject\login class=xyz data="blah" myattr="example">
<a href = test.html class=xyz data=' blah'>
<a href= "test . html" class=" xyz " data=blah>
<a href = ' ./test.html#bir/deneme/?k=1&v=1 ' class= "a xyz_bir-ahmet. abc">
<a href = ' ./test.html' class= 'xyz abc'>
<a href = ' .././test.html' class= 'xyz abc'>
<a href = 'test.html' class = " xyz ui abc">
<a href='test.html' class ='xyz ui abc'>
<a href="test.html" class=" xyz ui abc">
<a href= "test.html " class="xyz "data=blah>
<a href=test.html class="xyz " data=blah>
<a href=test.html class="xyz" data=blah>
<a href=test.html class = xyz data="blah">
<meta http-equiv="Set-Cookie" content="COOKIE2_VALUE_HERE">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}