# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^|[AB])0000/\1XXXX/gm;t' <<< "0000A0000B0000C0000D0000E0000A0000"