package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^|[AB])0000`)
var str = `0000A0000B0000C0000D0000E0000A0000`
var substitution = "\1XXXX"
fmt.Println(re.ReplaceAllString(str, substitution))
}