re = /(^|[AB])0000/m
str = '0000A0000B0000C0000D0000E0000A0000'
subst = '\\1XXXX'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result