// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^|[AB])0000").unwrap();
let string = "0000A0000B0000C0000D0000E0000A0000";
let substitution = "\\1XXXX";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}