const regex = /(^|[AB])0000/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|[AB])0000', 'gm')
const str = `0000A0000B0000C0000D0000E0000A0000`;
const subst = `\1XXXX`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);