#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^|[AB])0000"
Local $sString = "0000A0000B0000C0000D0000E0000A0000"
Local $sSubst = "\1XXXX"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)