import re
regex = re.compile(r"(^|[AB])0000", flags=re.MULTILINE)
test_str = "0000A0000B0000C0000D0000E0000A0000"
subst = "\\1XXXX"
result = regex.sub(subst, test_str)
if result:
print(result)