$re = '/(^|[AB])0000/m';
$str = '0000A0000B0000C0000D0000E0000A0000';
$subst = "\1XXXX";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;