use strict;
my $str = '0000A0000B0000C0000D0000E0000A0000';
my $regex = qr/(^|[AB])0000/mp;
my $subst = '\\1XXXX';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";