# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(\d{4})\d{6}\b/$1******/gm;t' <<< "arandomsensitive information: 1234567890 this is not senstive: 1234567890000000"