#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(\d{4})\d{6}\b"
Local $sString = "arandomsensitive information: 1234567890 this is not senstive: 1234567890000000"
Local $sSubst = "$1******"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)