using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\d{4})\d{6}\b";
string substitution = @"$1******";
string input = @"arandomsensitive information: 1234567890 this is not senstive: 1234567890000000";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}