package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(\d{4})\d{6}\b`)
var str = `arandomsensitive information: 1234567890 this is not senstive: 1234567890000000`
var substitution = "$1******"
fmt.Println(re.ReplaceAllString(str, substitution))
}