$re = '`\b(\d{4})\d{6}\b`m';
$str = 'arandomsensitive information: 1234567890 this is not senstive: 1234567890000000';
$subst = "$1******";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;