// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(\d{4})\d{6}\b").unwrap();
let string = "arandomsensitive information: 1234567890 this is not senstive: 1234567890000000";
let substitution = "$1******";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}