import re
regex = re.compile(r"\b(\d{4})\d{6}\b", flags=re.MULTILINE)
test_str = "arandomsensitive information: 1234567890 this is not senstive: 1234567890000000"
subst = "$1******"
result = regex.sub(subst, test_str)
if result:
print(result)