using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[a-z])[A-Z]|[A-Z](?=[^A-Z])";
string substitution = @"_\g<0>";
string input = @"'someWorkingTestingPhrase', 'shortMINEPasscode'";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}