import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[a-z])[A-Z]|[A-Z](?=[^A-Z])";
final String string = "'someWorkingTestingPhrase', 'shortMINEPasscode'";
final String subst = "_\\g<0>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}