$re = '/(?<=[a-z])[A-Z]|[A-Z](?=[^A-Z])/m';
$str = '\'someWorkingTestingPhrase\', \'shortMINEPasscode\'';
$subst = "_\g<0>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;