const regex = new RegExp('(?<=[a-z])[A-Z]|[A-Z](?=[^A-Z])', 'gm')
const str = `'someWorkingTestingPhrase', 'shortMINEPasscode'`;
const subst = `_\g<0>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);