import Foundation
let pattern = #"(?<=[a-z])[A-Z]|[A-Z](?=[^A-Z])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"'someWorkingTestingPhrase', 'shortMINEPasscode'"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"_\g<0>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)