re = /(?<=[a-z])[A-Z]|[A-Z](?=[^A-Z])/m
str = '\'someWorkingTestingPhrase\', \'shortMINEPasscode\''
subst = '_\\g<0>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result