# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?:INDIVIDUAL|BUSINESS)\b(*SKIP)(*F)|.//gm;t' <<< "|Name:James Indiana|type:INDIVIDUAL|Id::G123456789&M|Location:Indonesia|
|Name:James Bond|type:BUSINESS|Id::G&987654321M|Location:Indonesia|\")"