use strict;
my $str = '|Name:James Indiana|type:INDIVIDUAL|Id::G123456789&M|Location:Indonesia|
|Name:James Bond|type:BUSINESS|Id::G&987654321M|Location:Indonesia|")';
my $regex = qr/\b(?:INDIVIDUAL|BUSINESS)\b(*SKIP)(*F)|./mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";