import re
regex = re.compile(r"\b(?:INDIVIDUAL|BUSINESS)\b(*SKIP)(*F)|.", flags=re.MULTILINE)
test_str = ("|Name:James Indiana|type:INDIVIDUAL|Id::G123456789&M|Location:Indonesia|\n"
"|Name:James Bond|type:BUSINESS|Id::G&987654321M|Location:Indonesia|\")")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)