re = /\b(?:INDIVIDUAL|BUSINESS)\b(*SKIP)(*F)|./m
str = '|Name:James Indiana|type:INDIVIDUAL|Id::G123456789&M|Location:Indonesia|
|Name:James Bond|type:BUSINESS|Id::G&987654321M|Location:Indonesia|")'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result