const regex = /\b(?:INDIVIDUAL|BUSINESS)\b(*SKIP)(*F)|./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:INDIVIDUAL|BUSINESS)\\b(*SKIP)(*F)|.', 'gm')
const str = `|Name:James Indiana|type:INDIVIDUAL|Id::G123456789&M|Location:Indonesia|
|Name:James Bond|type:BUSINESS|Id::G&987654321M|Location:Indonesia|")`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);