package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(NICA)* *BOX +#? *[0-9]{4}$`)
var str = `NICA BOX #1122`
var substitution = "\4"
fmt.Println(re.ReplaceAllString(str, substitution))
}