import Foundation
let pattern = ##"^(NICA)* *BOX +#? *[0-9]{4}$"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"NICA BOX #1122"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)