import re
regex = re.compile(r"^(NICA)* *BOX +#? *[0-9]{4}$")
test_str = "NICA BOX #1122"
subst = "\\4"
result = regex.sub(subst, test_str)
if result:
print(result)