$re = '/^(NICA)* *BOX +#? *[0-9]{4}$/';
$str = 'NICA BOX #1122';
$subst = "\4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;