re = /^(NICA)* *BOX +#? *[0-9]{4}$/
str = 'NICA BOX #1122'
subst = '\\4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result