package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`rgba\([^$]`)
var str = `box-shadow: 0 0 3px 1px rgba(black, 0.2);
-webkit-box-shadow: 0 0 10px 0 rgba($black, 0.07);
background: rgba(236, 236, 236, 0.8);`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}