// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"rgba\([^$]").unwrap();
let string = "box-shadow: 0 0 3px 1px rgba(black, 0.2);
-webkit-box-shadow: 0 0 10px 0 rgba($black, 0.07);
background: rgba(236, 236, 236, 0.8);";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}